<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en"> <!--<![endif]-->
<head>
  <meta charset="utf-8">
  <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">	
		<title>
			Weekly Chart - WBRS 100.1 FM		</title>
		
		<meta name="viewport" content="width=1100">
			    
		<link rel="stylesheet" type="text/css" href="http://www.wbrs.org/wp-content/themes/wbrs/style.css" media="screen" />
		<link rel="stylesheet" type="text/css" href="http://www.wbrs.org/wp-content/themes/wbrs/jquery.bxslider.css" media="screen" />
		<link rel="alternate" type="application/rss+xml" title="WBRS 100.1 FM RSS Feed" href="http://www.wbrs.org/feed/" />
		<link rel="pingback" href="http://www.wbrs.org/xmlrpc.php" />
		<link rel="shortcut icon" href="http://www.wbrs.org/wp-content/themes/wbrs/images/favicon.ico" />
		
		<!--[if lt IE 9]>
		<script src="//html5shiv.googlecode.com/svn/trunk/html5.js"></script>
		<![endif]--> 
		
		<script src="http://www.wbrs.org/wp-content/themes/wbrs/js/vendor/modernizr-2.6.2.min.js"></script>
		
		
<!-- This site is optimized with the Yoast SEO plugin v7.0.3 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://www.wbrs.org/weekly-chart-5/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Weekly Chart - WBRS 100.1 FM" />
<meta property="og:description" content="New songs you need to check out! by Anna Bartusis Heaven Sent Mini Dresses Boston-based trio Mini Dresses just released Heaven Sent, and the title track is so beautiful. It&#8217;s slow-moving, but heavy, dreamy, and wistful. According to their Bandcamp, the album was recorded throughout 2017-18 and is &#8220;an album of accumulation &#8212; of spaces, moments in time,&hellip;" />
<meta property="og:url" content="http://www.wbrs.org/weekly-chart-5/" />
<meta property="og:site_name" content="WBRS 100.1 FM" />
<meta property="article:publisher" content="https://www.facebook.com/WBRSFM/" />
<meta property="article:section" content="New Music" />
<meta property="article:published_time" content="2019-03-23T18:15:25-04:00" />
<meta property="article:modified_time" content="2019-03-23T18:15:51-04:00" />
<meta property="og:updated_time" content="2019-03-23T18:15:51-04:00" />
<meta property="og:image" content="http://www.wbrs.org/wp-content/uploads/2019/03/weekly2.png" />
<meta property="og:image:width" content="496" />
<meta property="og:image:height" content="262" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/www.wbrs.org\/","sameAs":["https:\/\/www.facebook.com\/WBRSFM\/","https:\/\/www.instagram.com\/brandeiswbrs\/","https:\/\/www.linkedin.com\/company\/wbrs","https:\/\/www.google.com\/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0ahUKEwiX2Mfu9-baAhXBoRQKHR8cDU8QFggoMAA&url=https:\/\/www.youtube.com\/channel\/UCBOqxG6uqK4o2g1oAL0TwEw&usg=AOvVaw29SxTQVC5Bb3l04M9m7uq0","https:\/\/twitter.com\/wbrsfm"],"@id":"#organization","name":"WBRS 100.1 FM","logo":"http:\/\/www.wbrs.org\/wp-content\/uploads\/2015\/03\/logo.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//hosted.muses.org' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="WBRS 100.1 FM &raquo; Feed" href="http://www.wbrs.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="WBRS 100.1 FM &raquo; Comments Feed" href="http://www.wbrs.org/comments/feed/" />
<link rel="alternate" type="text/calendar" title="WBRS 100.1 FM &raquo; iCal Feed" href="http://www.wbrs.org/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="WBRS 100.1 FM &raquo; Weekly Chart Comments Feed" href="http://www.wbrs.org/weekly-chart-5/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.wbrs.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.10"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<script type='text/javascript' src='https://hosted.muses.org/mrp.js?ver=1.6'></script>
<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js?ver=1.8.3'></script>
<link rel='https://api.w.org/' href='http://www.wbrs.org/wp-json/' />
<link rel='shortlink' href='http://www.wbrs.org/?p=1420' />
<link rel="alternate" type="application/json+oembed" href="http://www.wbrs.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.wbrs.org%2Fweekly-chart-5%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.wbrs.org/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.wbrs.org%2Fweekly-chart-5%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://www.wbrs.org"><link rel="https://theeventscalendar.com/" href="http://www.wbrs.org/wp-json/tribe/events/v1/" />		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<link rel="icon" href="http://www.wbrs.org/wp-content/uploads/2014/01/logo_1988_144x152.jpg" sizes="32x32" />
<link rel="icon" href="http://www.wbrs.org/wp-content/uploads/2014/01/logo_1988_144x152.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://www.wbrs.org/wp-content/uploads/2014/01/logo_1988_144x152.jpg" />
<meta name="msapplication-TileImage" content="http://www.wbrs.org/wp-content/uploads/2014/01/logo_1988_144x152.jpg" />

	</head>

	<body class="post-template-default single single-post postid-1420 single-format-standard tribe-no-js">
	
		<!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
	
        <header>
        	<div id="header-content" class="container">
            <a href="http://www.wbrs.org"><img class="logo" src="http://www.wbrs.org/wp-content/themes/wbrs/images/logo.png" alt="WBRS" /></a>
            
            <div class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-33" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33"><a href="http://www.wbrs.org/about/">ABOUT US</a></li>
<li id="menu-item-182" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-182"><a href="http://www.wbrs.org/schedule/">SCHEDULE</a></li>
<li id="menu-item-306" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-306"><a href="http://www.wbrs.org/events/">EVENTS</a></li>
<li id="menu-item-123" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-123"><a href="http://www.wbrs.org/departments/">DEPARTMENTS</a></li>
<li id="menu-item-98" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-98"><a href="http://www.wbrs.org/services/">SERVICES</a></li>
<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-158"><a href="http://www.wbrs.org/blog/">BLOG</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26"><a href="http://www.wbrs.org/contact/">CONTACT</a></li>

	<script>
var launch_html5_player = function() {
  var win = window.open("web-player", "Title", "toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=yes,resizable=no,width=320,height=540,top="+(screen.height-400)+",left="+(screen.width-840));
}
</script><li class="listen-now-btn"><a href="#" onclick="launch_html5_player()">LISTEN NOW</a></li></ul></div>            
            	<ul id="header-social" class="clearfix">
            		<li class="social-fb"><a class="social-link" href="https://www.facebook.com/WBRSFM" target="_blank">Facebook</a></li>
            		<li class="social-tw"><a class="social-link" href="https://twitter.com/wbrsfm" target="_blank">Twitter</a></li>
					<li class="ig-link"><a class="ig-social-link" href="https://www.instagram.com/brandeiswbrs/" target="_blank">Instagram</a></li>
            		<li><strong>STUDIO #</strong> 781-736-4785</li>
            	</ul>
            </div>
        </header>
        <div id="content">
		<div class="container clearfix" id="blog-content">
		
			<h1>Weekly Chart</h1>
			<p class="post-meta">March 23rd, 2019 | <a href="http://www.wbrs.org/category/new-music/" rel="category tag">New Music</a></p>

			<p>New songs you need to check out!</p>
<p>by Anna Bartusis</p>
<h2><a href="https://minidresses.bandcamp.com/track/heaven-sent"><img class=" alignleft" src="https://f4.bcbits.com/img/a1714714956_16.jpg" width="290" height="290" /></a>Heaven Sent</h2>
<h3>Mini Dresses</h3>
<p>Boston-based trio Mini Dresses just released <em>Heaven Sent, </em>and the title track is so beautiful. It&#8217;s slow-moving, but heavy, dreamy, and wistful. According to their Bandcamp, the album was recorded throughout 2017-18 and is &#8220;an album of accumulation &#8212; of spaces, moments in time, emotions.&#8221; Mini Dresses&#8217; LP release show is April 4 at the Lilypad Inman, so if you like this track, don&#8217;t miss this show!</p>
<p>For fans of: Horse Jumper of Love, Chastity Belt, Fog Lake</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<h2><a href="https://nanamiozone.bandcamp.com/track/alone-too-3"><img class=" alignleft" src="https://f4.bcbits.com/img/a0479970089_10.jpg" width="290" height="289" /></a>Alone Too</h2>
<h3>Nanami Ozone</h3>
<p>&#8220;I don&#8217;t wanna be with you but I don&#8217;t wanna be alone too,&#8221; sings the lead, Sophie Opich, opening the track with this catchy phrase. This is an energetic indie song that&#8217;s questioning a relationship and our human need for company. &#8220;Alone Too&#8221; is from the Phoenix-based band&#8217;s new sophomore album, <em>NO. </em>Nanami Ozone will be stopping in Boston on May 14 at O&#8217;Brien&#8217;s, also joined by Hypoluxo.</p>
<p>For fans of: Lala Lala, Forth Wanderers, IAN SWEET</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<h2><a href="https://www.youtube.com/watch?v=YoCOh2r6ML0"><img class=" alignleft" src="https://i.scdn.co/image/54bc611e99c7587a5c38158eb1c706bc4276ccd1" width="290" height="290" /></a>Choose Go!</h2>
<h3>CHAI</h3>
<p>This is such a fun track that blends punk, indie, and pop all into an eclectic track that makes you want to dance. &#8220;Choose Go!&#8221; is from CHAI&#8217;s newest album, <em>PUNK. </em>CHAI is an all-female band from Japan that seeks to redefine the meaning of &#8220;kawaii.&#8221;  From the band&#8217;s website, &#8220;there should be many more types of kawaii, and everyone is kawaii in her own way. You should be who you are.&#8221; So wholesome, so PUNK.</p>
<p>For fans of: Kero Kero Bonito, Peach Kelli Pop, The Aquadolls</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<h2><a href="https://www.youtube.com/watch?v=DjZp417dpN4"><img class=" alignleft" src="https://f4.bcbits.com/img/a3930989516_16.jpg" width="290" height="290" /></a>February</h2>
<h3>Frankie Cosmos</h3>
<p>Frankie Cosmos is back at it again with a couple short new tracks, including this one, &#8220;February,&#8221; clocking it at just under 2 minutes. It&#8217;s hearkening back to the stripped-down simplicity and emotional vulnerability of <em>Zentropy. </em>This new digital-only installment of songs, <em>Haunted Items, </em>is being released weekly through April 3. &#8220;February&#8221; is paired with &#8220;In the World&#8221; in the second release of <em>Haunted Items. </em></p>
<p>For fans of: Adult Mom, Sidney Gish, Girlpool</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<h2><a href="https://petiteleague.bandcamp.com/track/white-knuckle-wildflower"><img class=" alignleft" src="https://f4.bcbits.com/img/a0962256368_16.jpg" width="290" height="290" /></a>White Knuckle Wildflower</h2>
<h3>Petite League</h3>
<p>Who doesn&#8217;t love a high-energy garage rock song? &#8220;White Knuckle Wildflower&#8221; is a taste of Petite League&#8217;s new album, which is still in the works. Lorenzo Cook, lead for the Brooklyn-based band, writes that the new album is &#8220;about trading dueling comforts and discomforts for a new ones, it’s about how green the grass really is where you’re standing versus where you’ve always been, and it’s about falling in love quickly and falling out of it just as fast.&#8221;</p>
<p>For fans of: Joy Again, Beach Bunny, Worn-Tin</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<h2><a href="https://open.spotify.com/track/4h7oFOj4ADl3dFWXafJCJm?si=oetip2l9RGWURS9V09CYQw"><img class=" alignleft" src="https://lh3.googleusercontent.com/79Xb-vMLq-FEp_bNUZ9AZGyaCwvaiP6FQq1x52WeMdi_x3pZDGmyUNF8WqusNcOkYIwEkWbqQg=w360-c-h360-e100-rwu-v1" width="290" height="290" /></a>Careful</h2>
<h3>I Experienced Love</h3>
<p>This song makes me feel like I&#8217;m walking the neon-lit rainy streets in <em>Bladerunner. </em>The overlapping channels of the sung lyrics makes it an ethereal, trance-like, 80&#8217;s-inspired track. Imagine if John Maus made actual vaporwave/chillwave music &#8211; this is it.</p>
<p>For fans of: John Maus, George Clanton, Part Time</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p>Check out this week&#8217;s Spotify playlist!</p>
<p><iframe src="https://open.spotify.com/embed/user/1219280951/playlist/6qpyekagy9i8vTLWmuCExI" width="300" height="380" frameborder="0"></iframe></p>

								
	</div>

		</div>
		<!--</END CONTENT>-->
        <footer>
        	<div class="sponsor-bar">
        		<div class="sponsor-bar-content container clearfix">
        			<div class="sponsor-bar-label">
        			THANK YOU TO <strong>OUR SPONSORS</strong>
        			</div>
        			<div class="sponsor-bar-logos clearfix">
        				        				        				<div class="sponsor-logo">
        					        					<img src="http://www.wbrs.org/wp-content/uploads/2017/09/download-e1504543918395.png" alt="Chillbox" />
        					        				</div>
        				        				<div class="sponsor-logo">
        					        					<img src="http://www.wbrs.org/wp-content/uploads/2017/09/primedeli-e1504651460454.gif" alt="Prime Deli" />
        					        				</div>
        				        				<div class="sponsor-logo">
        					        					<img src="http://www.wbrs.org/wp-content/uploads/2017/09/Brandeis_University_seal.svg_-e1504651815431.png" alt="Students of Brandeis University" />
        					        				</div>
        				        			</div>
        			
        			<a href="https://www.brandeis.edu/" target="_blank"><img class="brandeis-logo" src="http://www.wbrs.org/wp-content/themes/wbrs/images/brandeis.png" alt="From the campus of Brandeis University" /></a>
        		</div>
        	</div>
        	<div id="footer-content" class="container clearfix">
        	<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-14" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-14"><a href="http://www.wbrs.org/">Home</a></li>
<li id="menu-item-15" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15"><a href="http://www.wbrs.org/partners/">Partners</a></li>
<li id="menu-item-326" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-326"><a href="http://www.wbrs.org/sitemap/">Sitemap</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25"><a href="http://www.wbrs.org/contact/">Contact Us</a></li>

	<script>
var launch_html5_player = function() {
  var win = window.open("web-player", "Title", "toolbar=no,location=no,directories=no,status=no,menubar=no,scrollbars=yes,resizable=no,width=320,height=540,top="+(screen.height-400)+",left="+(screen.width-840));
}
</script><li class="listen-now-btn"><a href="#" onclick="launch_html5_player()">LISTEN NOW</a></li></ul></div>        	
        		<ul class="footer-copyright">
        			<li>&copy; 2014 WBRS & Brandeis University</li>
        			<li class="social-fb"><a class="social-link" href="https://www.facebook.com/WBRSFM " target="_blank">Facebook</a></li>
        			<li class="social-tw"><a class="social-link" href="https://twitter.com/wbrsfm" target="_blank">Twitter</a></li>
					<li class="ig-link"><a class="ig-social-link" href="https://www.instagram.com/brandeiswbrs/" target="_blank">Instagram</a></li>
        		</ul>
        	</div>
        </footer>

		
				<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script type='text/javascript' src='http://www.wbrs.org/wp-includes/js/wp-embed.min.js?ver=4.9.10'></script>
		
        <script src="http://www.wbrs.org/wp-content/themes/wbrs/js/plugins.js"></script>
        <script src="http://www.wbrs.org/wp-content/themes/wbrs/js/main.js"></script>
        
	</body>

</html>